Damage Indicators Mod 1.12.2/1.12.1/1.12/1.11.2 for Minecraft

The Damage Indicators Mod is a great PvP Mod for Minecraft. It shows a Mob portrait preview with current health of mobs and players when you mouse over them! Damage Indicators Mod is compatible with all types of Mobs. This Mod requires Minecraft Forge to work properly. According to 9minecraft there are 1.12 versions of Damage Indicators available. However, in the official MinecraftForum thread you can only browse trough 1.8/1.7 Downloads of the Mod. The Mod adds this great health bar preview to the game. You can use Damage Indicators with Optifine. Below we provide you a short installation guide and the download links of Damage Indicators.

Damage Indicators Mod for Minecraft Changelogs

  • Fixed Online Compatibility
  • Fixed servers crashing from mods (server side)

What’s new in the 1.12.2/1.12.1 version?

  • Entity scaling has been improved
  • Bar mode + two optional skins were added
  • Mod display now even works trough grass
  • x y offsets are aslways applied for now (custom layout got removed)

How to Install Damage Indicators Mod 1.12.1/1.12.2

  1. Download and install Forge API
  2. Run Minecraft one time
  3. Download Damage Indicators jar file (listed below)
  4. Select profile to be Install Damage Indicators Mod after opening Minecraft again
  5. Enjoy!

How to Install Damage Indicators Mod 1.12.2/1.12.1/1.11.2 with Forge

  1. Download and install the Forge Installer
  2. Right click on the Forge Installer and then press “OK” to install it.
  3. Press WIN+R, type in %appdata%, press enter then.
  4. Navigate to Roaming/.minecraft/mods
  5. After that just put the Damage Indicators Mod into your mods folder.
  6. Run Minecraft! 🙂 Enjoy!

Damage Indicators Mod 1.12.2/1.12.1/1.12/1.11.2 Screenshots

Damage Indicators 1.12.2/1.12.1/1.11.2/1.11/1.10.2/1.10
Damage Indicators 1.12.2/1.12.1/1.11.2/1.11/1.10.2/1.10

Download Links for Damage Indicators Mod

Damage Indicators Installer for Minecraft 1.12.1
[1.12.1] Damage-Indicator-1.11.2.jar (67.16 KB)

Damage Indicators Installer for Minecraft 1.12
[1.12] Damage-Indicators-1.12.jar (66.44 KB)

Damage Indicators Installer for Minecraft 1.11.2
[1.11.2] Damage-Indicator-1.11.2.jar (67.16 KB)

Damage Indicators Installer for Minecraft 1.11
[1.11] Damage-Indicators-1.11.jar (46.27 KB)

Damage Indicators Installer for Minecraft 1.10.2
[1.10] Damage-Indicators-1.10.2.jar (46.24 KB)

Damage Indicators Installer for Minecraft 1.9.4
[1.9.4] Damage-indicators-1.9.4.jar (46.24 KB)

Damage Indicators Installer for Minecraft 1.8
[1.8] DamageIndicatorsMod-3.3.3.jar

Damage Indicators Installer for Minecraft 1.7.10
[1.7.10] DamageIndicatorsMod-3.2.3.jar

Credit: rich1051414 – Original Thread on MinecraftForum.

3 COMMENTS

  1. Welp, I’m officially pissed! Currently the only download links there are is 1.7.9 and 1.8. So why tf does it say 1.12 and 1.11.2 are included!

LEAVE A REPLY